




A P P L E  I P H O T O  6

your new playlist.  To move multiple songs, click the 
Command key or the Shift key and click on the songs 
you desire and then drag them together as a group into 
your new playlist.

10. To remove a song from a playlist, select it and hit the De-
lete key. (Note:  This does not remove it from the iTunes 
Library or from the hard disk, only from the Playlist.)

11. Now, go into iPhoto and select the slideshow that you 
created and click on the Music button. Select the new 
playlist you created from the pull-down menu (e.g., Music 
for iPhoto) and then select the tune you wish to use in 
your slideshow in the list that appears or use the Search 
box to search for the tune. Click the OK button to close 
this dialog box and save your choices.

Export a Slideshow as a QuickTime Movie
This is a cool feature of  iPhoto.  Did you know that you can 
export your slideshow into a QuickTime movie and play it on 
any computer that has QuickTime installed (Mac or PC)?  To 
make a QuickTime movie of your photos, follow the steps 
below:

1. Select the album of photos you want in your movie.  
Make sure that none of the photos are selected by 
choosing Edit > Select None; otherwise, you’ll have a 
movie of only the photos that are selected in the album.

2. Choose File > Export…

3. When the Export Photos dialog box appears, click on the 
QuickTime tab (see Figure 27).

Figure 27:  Export Photos - QuickTime Movie

4. In the QuickTime pane, change the desired options:

Images: Specify the maximum dimensions of your 
movie in pixels and set the display duration for each 
photo.

Background: To add a background color to your 
movie, click the Color button, then click the color 
preview box to change the color. To add a back-
ground image, click the Image button, then click Set 
to select an image.

Music: Choose whether or not to include the same 
background music selected in the Slideshow Settings 
window. 

5. Click Export.

6. Type a name for your movie and choose where to save it 
(e.g., the Desktop).

7. Click Save.

Export a Slideshow as HTML Web Pages 
This is another really cool feature of iPhoto. Did I say that all 
of the features are cool?  You can export your slideshow into 
HTML so that it is organized on a web page for you with 
thumbnails that visitors can click on and see a larger version 
of your prized photos. Here’s how:

1. Make a new folder on your Desktop (Command+Shift+N) 
and give the folder a title (e.g., iPhoto Web Page)

2. Open iPhoto and select the photo album you wish to 
make into a web page. Make sure that none of the pho-
tos are selected by choosing Edit > Select None; other-
wise, you’ll have a movie of only the photos that are se-
lected in the album.

3. Go to File > Export…

4. When the Export Photos dialog box appears, click on the 
tab labeled Web Page.

Figure 28:  Export Photos - Web Pages
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5. In the Web Page pane, change the desired options:

Page: Type a name for your web page and specify 
the number of columns and rows per page. To add a 
background color, click the Color button, then click 
the color preview box to change the color. To add a 
background image, click the Image button, then click 
Set... to select an image. To change text color, click 
the Text Color button.

Thumbnail: Specify the maximum dimensions in pix-
els for your photo thumbnails. Click the "Show title" 
or "Show comment" checkbox if you want your 
thumbnails to have titles or comments.

Image: Specify the maximum dimensions in pixels for 
your photos. Click the "Show title" or "Show com-
ment" checkbox if you want titles or comments to 
appear on your web page.

6. Click Export.

7. Navigate to the new folder (i.e., iPhoto Web Page) that 
you created on the Desktop earlier in Step 1 above and 
click the OK button to save your web page. By doing 
this, all the content for the web page is placed in one 
folder for easy upload to a server or to your Sites or Web 
folder in your .Mac account. iPhoto will create a .html file 
that has the same name as the new folder you previously 
created on the Desktop and will also generate three fold-
ers within the first folder your created. which contains 
images, pages, and thumbnails.

8. To preview your page before publishing it on a web 
server, drag the .html page into your browser (e.g., Safari, 
Internet Explorer,  or Netscape). Notice how the main 
.html page with thumbnails allows you to double-click on 
an image and see the larger image.  iPhoto has also gen-
erated web pages for the larger images (non-thumbnails), 
which allows for navigation to Previous or Next images.

9. NOTE: Be sure when you upload these files onto a web 
server that you upload the entire folder containing all the 
subfolders.

Exporting Photos for Other Purposes
You may wish to export your photos from an album to send 
to someone in an email or to import into another application.  
iPhoto makes this task very simple and allows you to config-
ure the exact size of the exported photos.

1. Create a new folder on your Desktop (Com-
mand+Shift+N) and give it a name (e.g., Photos Export)

2. Select the photo(s) or a photo album you want to export.

3. Choose File > Export…

4. When the dialog box appears, click the File Export tab 
(Figure 29).

Figure 29:  Export Photos - File Export

5. In the File Export pane, change the desired options:

Format:  Choose a file format for your exported im-
ages from the pull-down menu (e.g., Original, JPG, 
TIFF, or PNG) 

Size:  If necessary, scale the images to a specific size 
by specifying a maximum width and height.

Name:  Choose whether to export photos with their 
filenames, iPhoto titles, or album name. 

Extension:  Choose whether to add the file format 
extensions (such as .jpg or .tiff) to the end of the pho-
tos’ filenames, titles, or album names.

6. Click the Export button.

7. Navigate to the new folder you created previously on your 
Desktop (i.e., Photos Export) and then click the OK but-
ton to save the files in their new format to the folder for 
easy retrieval later.

Creating a Photo Book
You can choose from a variety of book sizes and designs to 
create photo albums for any occasion.

1. Select an album or group of photos you want in your 
book.

2. Click on the Book button.

3. Choose a hardcover or softcover book size from the 
Book Type pop-up menu.  (Note:  Softcover books are a 
new feature in iPhoto 5.)

4. Select a design for your book from the scrolling themes 
list.
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5. When you select a book theme, you can see an example 
of it in the window to the right of the themes list. If you 
want to go to the iPhoto website to see detailed book 
descriptions and pricing, click the Options + Prices but-
ton.

6. If you chose a hardcover book and want photos to be 
printed on only one side of your book pages, deselect the 
"Double-sided pages" checkbox.

7. Click Choose Theme.

8. Do one of the following:

a) Drag photos from the top of the iPhoto window 
onto your book pages. 

b) If you want iPhoto to automatically design your 
book by arranging the selected photos on each page 
for you, click the Autoflow button.

9. iPhoto switches to book view, and your new book ap-
pears in the Source list.

10. If you want, type a new name for your book in the Source 
list.

11. Once you create a book, you can change the order of 
pages or photos, add and change the appearance of text, 
and even customize the design of individual pages.

12. For more information on specific settings and features of 
creating a photo book, please refer to the Help menu in 
iPhoto and type in the search word “book”.

Sending a Photo Through Email
You can also send photos from your iPhoto Library or from 
photo albums directly from iPhoto with the help of your email 
program.

1. Select the photo or photos you want to mail. (Note: You 
can't email photos from a slideshow, book, calendar, or 
card.)

2. Choose Share > Email or click on the Email icon at the 
bottom of the iPhoto window.

Figure 30: Mail Photo Dialog Box

3. Choose a size for your emailed photos from the Size: 
pop-up menu.

4. Choose whether to include titles and comments.

5. Click Compose.

6. iPhoto opens a New Message window in Mac OS X Mail 
with the photo or photos attached. (Note: If you want to 
mail photos using Entourage, Eudora, or AOL, install the 
application on your computer, choose iPhoto > Prefer-
ences, click General at the top of the Preferences win-
dow, and then choose the application from the "Email 
photos using" pop-up menu.)

7. Enter an address, a subject line, and the text of the mes-
sage from your email software; then click Send.

IMPORTANT: If you send many large photos in a message, it 
will take longer for people to download them. It's a good idea 
to limit the size and number of photos you send in an email. If 
you have a lot to send, consider sending several different 
emails or using Photocasting. 

Print a Photo as a Greeting Card
You can print out your photos in a number of different ways:

1. Go to File > Print...

Figure 31:  Print Dialog Box

2. You will see from the Style:  pop-up menu that there are 
quite a few different choices:  Contact Sheet, Full Page, 
Greeting Card, N-Up, Sampler, and Standard Prints.

3. To print a greeting card, select Greeting Card from the 
Style: pop-up menu and then choose the Style: radio 
button you desire next to Single-fold or Double-fold.

4. Select the number of copies you wish to have printed and 
click on the Print button.
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Export a Photo in PDF Format
You can save a photo or an photo album as a PDF file. 

1. Click on a photo album and click on an individual photo.

2. Go to File > Print… and select the Style you desire.  
However, instead of selecting the Print button, click on 
the PDF... button and select Save As PDF...

3. When the Save to File dialog box appears, navigate to 
where you wish to save it and in the Save As… textbox, 
type the name of the file and add the .pdf extension.

4. Click on the Save button and iPhoto will save the photo 
as a PDF and place it in the location where you told it to 
save the file.

Burn a Photo Album to a CD or DVD
iPhoto has a built-in feature that allows you to put your 
iPhoto Library or a specific photo album or even specific indi-
vidual pictures on a CD or DVD and burn them.

IMPORTANT: Use iPhoto’s burn feature only to archive your 
photos and albums for viewing in iPhoto. If you need to cre-
ate a disc to be viewed by a Windows computer or a photo 
processing company, use the Burn Disc command within the 
Finder instead!

1. Click on individual photos, a photo album, or your entire 
iPhoto Library (this is great for backups).

2. Select Share > Burn or click on the Burn icon at the bot-
tom of the iPhoto window.

 

Figure 32:  Burn Button

3. Insert a blank CD-R , CD-RW, or DVD-R disc into the 
drive and click OK. Disc information appears at the bot-
tom of the iPhoto viewing area. The green area on the 
disc icon represents the amount of disc space your pho-
tos require.

4. If necessary, type a new name for the disc in the Name 
field and then click the Burn button.

5. Click the Burn button in the Burn Disc dialog.

6. It may take several minutes to write the disc. You can 
cancel the burn by clicking the Stop button next to the 
progress bar, but if you're using a CD-R disc, you might 
not be able to use the CD after canceling.

Set a Photo to Your Desktop Background
You probably already know that you can easily set a photo or 
image to be the background Desktop image for your com-
puter by going into your System Preferences and making 
the appropriate changes in the Desktop & Screensaver area, 
but iPhoto will allow you to do this right within iPhoto. 

NOTE: DO NOT DO THESE NEXT STEPS IF YOU ARE IN A 
LAB!

iPhoto makes it easy for you to assign any picture in the 
iPhoto Library as your Desktop image.

1. Select the photo in the photo library or an album.

2. Choose Share > Desktop or click on the Desktop icon 
at the bottom of the iPhoto window.

3. The Desktop will change displaying the photo that you 
selected as the background image.

4. You can also have your Desktop image cycle through a 
series of photos. Select an album or group of photos, 
choose Share > Desktop, and choose how often you 
want the picture to change from the Change picture 
pop-up menu (e.g., Every 30 minutes, every hour, every 
day, etc.) and make sure the checkmark is selected next 
to it. Close out this dialog box to save your changes.

Figure 33:  Desktop Dialog Box
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Set an iPhoto Album as a Screen Saver
To protect your display, you can set a screen saver to appear 
automatically if your computer hasn't been used for several 
minutes. If you want, you can use an album from your iPhoto 
Library as your screen saver. The photos appear one after the 
other, like a slideshow.

1. Select an album and choose Edit > Select None.

2. Choose Share > Desktop and when the Desktop & 
Screen Saver dialog box appears, click the Screen 
Saver tab. 

Figure 34:  Screen Saver Dialog Box

3. Select the amount of time before the screen saver comes 
on when there is no activity on your Mac by dragging the 
"Start screen saver" control.

4. If you want to set a different album as the Screen Saver 
instead, select it from the Screen Savers list on the left 
of this dialog box.

Sharing Photos Over a Network
Did you know that you can share your iPhoto images over the 
same network? This is a great feature if you have two or more 
Macs in your household (lucky you!) or in your office. Using 
this feature can save you some hard drive space because you 
can access your pictures but only have them on one com-
puter. As long as you have your Macs connected to a net-
work and iPhoto is running on your main Mac, you can ac-
cess all your photos from any of your other computers.

1. Go to iPhoto > Preferences and click on the Sharing 
icon.

2. Select the checkbox next to Share my photos.

3. Instead of sharing your whole library, it is best to select 
Share selected albums and then choose the ones you 
wish to see from your other Macs.

4. You can set a name and password to restrict access to 
people on your network. (Don’t forget to supply them with 
the name and password!) IMPORTANT: If you don’t 
password protect it, anyone will be able to view your 
photos - BAD IDEA!

5. Now from the other Macs, go into iPhoto and open the 
same dialog box by going to iPhoto > Preferences > 
Sharing  and then select Look for shared photos. The 
shared photos will appear in an album on your iPhoto 
Source list.

6. You cannot edit the pictures on a shared network but you 
can place them into a slideshow. If you wish, you may 
drag the photos into your own Library on the additional 
networked Macs and then edit them.

iPhoto 6 Keyboard Shortcuts
You can use your keyboard to quickly accomplish many tasks 
in iPhoto. To find the shortcuts for common commands, look 
in the menus (or see the menu shortcuts below). To do an 
action, press the keys indicated below on the next page.
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Action Shortcut

Import Photos Shift-Command-I

Move to the top of the 
photo library

Home

Move to the bottom of the 
photo library

End

Create new folder Shift-Command-Option-N

Create new album Command-N

Create new album from se-
lection

Shift-Command-N

Create new Smart Album Option-Command-N

Show or hide titles Shift-Command-T

Show or hide keywords Shift-Command-K

Show or hide film rolls Shift-Command-F

Show or hide all film rolls 
photos

Hold down the Option key 
and click the triangle next to 
any film roll

Show or hide ratings Shift-Command-R

Set the title, date, or com-
ments of multiple photos

Shift-Command-B

Assign, edit, or search by 
keywords

Command-K

Show a photo’s image and 
camera information

Command-I

Duplicate a photo Command-D

Cut photo Command-X

Copy photo Command-C

Paste photo Command-V

Move photo to Trash from 
the library or remove photo 
from album

Delete

Move photo to Trash from 
album

Command-Option-Delete

Open photo in its own win-
dow or in edit view (de-
pends on the double-click 
preference you set)

Double-click the photo

Action Shortcut

Select a single photo Click the photo

Select all photos Command-A

Select all photos between Hold down the Shift key and 
the current selection and a click the non-adjacent 
non-adjacent photo photo

Select photos that are non- Select the first photo, then 
adjacent to each other hold down the Command 

key and click additional 
photos

Select several photos lo- Click outside the photos 
cated together and drag to enclose them 

within the selection rectan-
gle

Select all photos in a film Click the film roll icon
roll

Deselect specific photos in Hold down the Command 
a group of selected photos key and click the photos 

you want to deselect

Deselect all photos Shift-Command-A or click 
outside a photo

Assign zero stars to a photo Command-0

Assign one star to a photo Command-1

Assign two stars to a photo Command-2

Assign three stars to a Command-3
photo

Assign four stars to a photo Command-4

Assign five stars to a photo Command-5

Stop a slideshow Press the mouse button

Pause and resume playing a Press the Space bar
slideshow

Adjust the speed of a slide- Use the Up and Down Ar-
show row keys

Move through a slideshow Use the Right and Left Ar-
manually row keys

Rate photos in a slideshow Press 0, 1, 2, 3, 4, or 5

Rotate photo clockwise Command-R
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Action Shortcut

Rotate photo counter 
clockwise

Option-Command-R or 
press the Option key while 
clicking the Rotate button

Go to next photo Press the Right Arrow key

Go to previous photo Press the Left Arrow key

Undo last action Command-Z

Redo last action Shift-Command-Z

Show fonts Command-T

Spelling Command-colon (:)

Print Command-P

Page Setup Shift-Command-P

Show preferences Command-, (comma)

iPhoto Help Command-?

Close window Command-W

Minimize window Command-M

Hide iPhoto Command-H

Quit iPhoto Command-Q

Using iPhoto in the University Classroom
Digital cameras offer teachers unlimited opportunities to en-
gage students and to incorporate technology into their cur-
riculum. At Cal Poly students, faculty, and staff can check out 
digital still cameras from Media Distribution Services 
(http://mds.calpoly.edu)  in Building 2 on the first floor.  Check 
out a camera and experiment with some student projects.  

Here are some examples of projects you can assign:

1. Assign pairs of students to take pictures on a topic re-
lated to class and compose their own iPhoto slideshow; 
then have them describe the slideshow to the class in a 
class presentation as it plays on a data projector or post 
it into Blackboard.

2. Have foreign language students take pictures of everyday 
things and put into an iPhoto slideshow or web page with 
a title and comments in Spanish/French/ Italian vocabu-
lary. Or if you prefer, keep the pictures in an iPhoto album 
arrangement and have them printed out for a classroom 

"Pictionary" so your students can quiz each other on for-
eign language vocabulary in class.

3. Take photos of your students the first day of class with 
your digital camera and create a directory that you can 
post in Blackboard to acquaint the students with one an-
other.

4. Take photos of your students the first day of class and 
export the pictures into small images that you can import 
into a Word document.  Add names and useful informa-
tion about the students to help you remember them.  This  
is a great way to help you learn students’ names more 
quickly, especially in a large lecture hall.

5. Take a picture of each student in your class and send the 
file with the iPhoto email tool for the student to post in 
Blackboard with their own personal Blackboard home 
page.  On their home page, students can share informa-
tion about themselves with their classmates, express ca-
reer interests or favorite links.

6. Take a digital camera on a class field trip. When you re-
turn to the classroom, have each student select a picture 
to label with a short description of what was happening 
or why this was important; then print a copy for everyone 
so they can remember what they learned on the trip.

7. Document the growth of a school project:  (e.g., a school 
construction project; planting and growing of a class gar-
den; changes in animals in a laboratory, etc.) Assign a 
new “class photographer” every week and have them 
document moments that demonstrate “learning in action” 
with a short description of what was happening and post 
the photos and descriptions in Blackboard.

8. Take photos of student final projects in 3-D form and post 
them in Blackboard.

 Obviously, this is just a short list of the many ways a digital 
camera can enhance instruction in the classroom. Enjoy 
yourself!  Be creative!  Think up some projects that will work 
for your discipline and get out there and start snapping pho-
tos!
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